re = /LINK\s*\(\s*([^\s,]+(?:\s[^\s,]+)*)\s*,\s*(\S+)\s*\)/
str = 'LINK( some anchor text , http://mydomain.com )'
subst = '<a class="inlinelink" target="blank" href="$2">$1</a>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result