#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "LINK\s*\(\s*([^\s,]+(?:\s[^\s,]+)*)\s*,\s*(\S+)\s*\)"
Local $sString = "LINK( some anchor text , http://mydomain.com )"
Local $sSubst = "<a class="inlinelink" target="blank" href="$2">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)