$re = '/LINK\s*\(\s*([^\s,]+(?:\s[^\s,]+)*)\s*,\s*(\S+)\s*\)/';
$str = 'LINK( some anchor text , http://mydomain.com )';
$subst = "<a class=\"inlinelink\" target=\"blank\" href=\"$2\">$1</a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;