package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w+.]+@[\w.-]+)`)
var str = `All of these emails should be valid (matched by the Regex):
tes.t@gmail.co.uk
q@q.com
a+2@gmail.com
+sd@gmail.com
a++abc@gmail.com
asdf.asdf@test-dom-a.com
All of these emails should be INVALID:
·$(")@gmail.com
(((@q.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}