const regex = /([\w+.]+@[\w.-]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w+.]+@[\\w.-]+)', 'g')
const str = `All of these emails should be valid (matched by the Regex):
tes.t@gmail.co.uk
q@q.com
a+2@gmail.com
+sd@gmail.com
a++abc@gmail.com
asdf.asdf@test-dom-a.com
All of these emails should be INVALID:
·\$(")@gmail.com
(((@q.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}