use strict;
my $str = 'All of these emails should be valid (matched by the Regex):
tes.t@gmail.co.uk
q@q.com
a+2@gmail.com
+sd@gmail.com
a++abc@gmail.com
asdf.asdf@test-dom-a.com
All of these emails should be INVALID:
·$(")@gmail.com
(((@q.com';
my $regex = qr/([\w+.]+@[\w.-]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}