import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w+.]+@[\\w.-]+)";
final String string = "All of these emails should be valid (matched by the Regex):\n\n"
+ "tes.t@gmail.co.uk\n"
+ "q@q.com\n"
+ "a+2@gmail.com\n"
+ "+sd@gmail.com\n"
+ "a++abc@gmail.com\n"
+ "asdf.asdf@test-dom-a.com\n\n"
+ "All of these emails should be INVALID:\n\n"
+ "·$(\")@gmail.com\n"
+ "(((@q.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}