import re
regex = re.compile(r"([\w+.]+@[\w.-]+)")
test_str = ("All of these emails should be valid (matched by the Regex):\n\n"
"tes.t@gmail.co.uk\n"
"q@q.com\n"
"a+2@gmail.com\n"
"+sd@gmail.com\n"
"a++abc@gmail.com\n"
"asdf.asdf@test-dom-a.com\n\n"
"All of these emails should be INVALID:\n\n"
"·$(\")@gmail.com\n"
"(((@q.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")