#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[tab color="(#[0-9a-f]{6})"\]([^\[]*)\[\/tab\]"
Local $sString = " An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type. [tab color="#fff000"] [/tab] An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")