package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[tab color="(#[0-9a-f]{6})"\]([^\[]*)\[\/tab\]`)
var str = ` An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type. [tab color="#fff000"] [/tab] An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}