re = /\[tab color="(#[0-9a-f]{6})"\]([^\[]*)\[\/tab\]/i
str = ' An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type. [tab color="#fff000"] [/tab] An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end