// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)\[tab color="(#[0-9a-f]{6})"\]([^\[]*)\[\/tab\]"#).unwrap();
let string = " An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type. [tab color=\"#fff000\"] [/tab] An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}