const regex = /\[tab color="(#[0-9a-f]{6})"\]([^\[]*)\[\/tab\]/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[tab color="(#[0-9a-f]{6})"\\]([^\\[]*)\\[\\\/tab\\]', 'i')
const str = ` An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type. [tab color="#fff000"] [/tab] An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}