import re
regex = re.compile(r"\[tab color=\"(#[0-9a-f]{6})\"\]([^\[]*)\[\/tab\]", flags=re.IGNORECASE)
test_str = " An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type. [tab color=\"#fff000\"] [/tab] An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type.An explanation of your regex will be automatically generated as you type."
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")