using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"filename=\""(\w*.*)""";
string input = @"--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
charset=us-ascii
Cordialement.
Non prenom
--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154
Content-Disposition: attachment;
filename=""mes candidatures.txt""
Content-Type: text/plain;
name=""mes candidatures.txt""
Content-Transfer-Encoding: quoted-printable
ici la piece jointe en texte B64";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}