const regex = /filename=\"(\w*.*)"/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('filename=\\"(\\w*.*)"', 'gmi')
const str = `--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
charset=us-ascii
Cordialement.
Non prenom
--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154
Content-Disposition: attachment;
filename="mes candidatures.txt"
Content-Type: text/plain;
name="mes candidatures.txt"
Content-Transfer-Encoding: quoted-printable
ici la piece jointe en texte B64`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}