import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "filename=\\\"(\\w*.*)\"";
final String string = "--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154\n"
+ "Content-Transfer-Encoding: 7bit\n"
+ "Content-Type: text/plain;\n"
+ " charset=us-ascii\n\n"
+ "Cordialement.\n\n"
+ "Non prenom\n\n"
+ "--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154\n"
+ "Content-Disposition: attachment;\n"
+ " filename=\"mes candidatures.txt\"\n"
+ "Content-Type: text/plain;\n"
+ " name=\"mes candidatures.txt\"\n"
+ "Content-Transfer-Encoding: quoted-printable\n\n"
+ "ici la piece jointe en texte B64";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}