# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"filename=\"(\w*.*)\""
test_str = ("--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154\n"
"Content-Transfer-Encoding: 7bit\n"
"Content-Type: text/plain;\n"
" charset=us-ascii\n\n"
"Cordialement.\n\n"
"Non prenom\n\n"
"--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154\n"
"Content-Disposition: attachment;\n"
" filename=\"mes candidatures.txt\"\n"
"Content-Type: text/plain;\n"
" name=\"mes candidatures.txt\"\n"
"Content-Transfer-Encoding: quoted-printable\n\n"
"ici la piece jointe en texte B64")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.