package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)filename=\"(\w*.*)"`)
var str = `--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
charset=us-ascii
Cordialement.
Non prenom
--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154
Content-Disposition: attachment;
filename="mes candidatures.txt"
Content-Type: text/plain;
name="mes candidatures.txt"
Content-Transfer-Encoding: quoted-printable
ici la piece jointe en texte B64`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}