using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span([^<]*)>(.*?)<\/span>";
string input = @"<p>Given <span class=""label"">Butter's game, the tree counts as more than one input.</p>
<p>Given <span class=""label"">Butter'</span>;s game, the tree counts as more than one input.</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}