import re
regex = re.compile(r"<span([^<]*)>(.*?)<\/span>", flags=re.MULTILINE)
test_str = ("<p>Given <span class=\"label\">Butter's game, the tree counts as more than one input.</p>\n"
"<p>Given <span class=\"label\">Butter'</span>;s game, the tree counts as more than one input.</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")