package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<span([^<]*)>(.*?)<\/span>`)
var str = `<p>Given <span class="label">Butter's game, the tree counts as more than one input.</p>
<p>Given <span class="label">Butter'</span>;s game, the tree counts as more than one input.</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}