re = /<span([^<]*)>(.*?)<\/span>/m
str = '<p>Given <span class="label">Butter's game, the tree counts as more than one input.</p>
<p>Given <span class="label">Butter'</span>;s game, the tree counts as more than one input.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end