# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\/\* )logger\..+?\);(?! \*\/)/\/* $0 *\//gs;t' <<< "logger.info( \"Log Message: [\" + myVariable
+ \"] is has a value of: [\" + myVariable.getValue() + \" ]\"
+ LogColors.ANSI_RESET );
/* logger.info( \"Log Message: [\" + myVariable
+ \"] is has a value of: [\" + myVariable.getValue() + \" ]\"
+ LogColors.ANSI_RESET ); */
logger.info( \"Log Message: [\" + myVariable
+ \"] is has a value of: [\" + myVariable.getValue() + \" ]\"
+ LogColors.ANSI_RESET );
logger.info( \"Log Message: [\" + myVariable
+ \"] is has a value of: [\" + myVariable.getValue() + \" ]\"
+ LogColors.ANSI_RESET );
"