import Foundation
let pattern = #"(?<!/\* )logger\..+?\);(?! \*/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
logger.info( "Log Message: [" + myVariable
+ "] is has a value of: [" + myVariable.getValue() + " ]"
+ LogColors.ANSI_RESET );
/* logger.info( "Log Message: [" + myVariable
+ "] is has a value of: [" + myVariable.getValue() + " ]"
+ LogColors.ANSI_RESET ); */
logger.info( "Log Message: [" + myVariable
+ "] is has a value of: [" + myVariable.getValue() + " ]"
+ LogColors.ANSI_RESET );
logger.info( "Log Message: [" + myVariable
+ "] is has a value of: [" + myVariable.getValue() + " ]"
+ LogColors.ANSI_RESET );
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/* $0 */"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)