#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?<!/\* )logger\..+?\);(?! \*/)"
Local $sString = "logger.info( "Log Message: [" + myVariable " & @CRLF & _
" + "] is has a value of: [" + myVariable.getValue() + " ]"" & @CRLF & _
" + LogColors.ANSI_RESET );" & @CRLF & _
"/* logger.info( "Log Message: [" + myVariable " & @CRLF & _
" + "] is has a value of: [" + myVariable.getValue() + " ]"" & @CRLF & _
" + LogColors.ANSI_RESET ); */" & @CRLF & _
"logger.info( "Log Message: [" + myVariable " & @CRLF & _
" + "] is has a value of: [" + myVariable.getValue() + " ]"" & @CRLF & _
" + LogColors.ANSI_RESET );" & @CRLF & _
"logger.info( "Log Message: [" + myVariable " & @CRLF & _
" + "] is has a value of: [" + myVariable.getValue() + " ]"" & @CRLF & _
" + LogColors.ANSI_RESET );" & @CRLF & _
""
Local $sSubst = "/* $0 */"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)