using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!/\* )logger\..+?\);(?! \*/)";
string substitution = @"/* $0 */";
string input = @"logger.info( ""Log Message: ["" + myVariable
+ ""] is has a value of: ["" + myVariable.getValue() + "" ]""
+ LogColors.ANSI_RESET );
/* logger.info( ""Log Message: ["" + myVariable
+ ""] is has a value of: ["" + myVariable.getValue() + "" ]""
+ LogColors.ANSI_RESET ); */
logger.info( ""Log Message: ["" + myVariable
+ ""] is has a value of: ["" + myVariable.getValue() + "" ]""
+ LogColors.ANSI_RESET );
logger.info( ""Log Message: ["" + myVariable
+ ""] is has a value of: ["" + myVariable.getValue() + "" ]""
+ LogColors.ANSI_RESET );
";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}