import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!/\\* )logger\\..+?\\);(?! \\*/)";
final String string = "logger.info( \"Log Message: [\" + myVariable \n"
+ " + \"] is has a value of: [\" + myVariable.getValue() + \" ]\"\n"
+ " + LogColors.ANSI_RESET );\n"
+ "/* logger.info( \"Log Message: [\" + myVariable \n"
+ " + \"] is has a value of: [\" + myVariable.getValue() + \" ]\"\n"
+ " + LogColors.ANSI_RESET ); */\n"
+ "logger.info( \"Log Message: [\" + myVariable \n"
+ " + \"] is has a value of: [\" + myVariable.getValue() + \" ]\"\n"
+ " + LogColors.ANSI_RESET );\n"
+ "logger.info( \"Log Message: [\" + myVariable \n"
+ " + \"] is has a value of: [\" + myVariable.getValue() + \" ]\"\n"
+ " + LogColors.ANSI_RESET );\n";
final String subst = "/* $0 */";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}