# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!/\* )logger\..+?\);(?! \*/)"
test_str = ("logger.info( \"Log Message: [\" + myVariable \n"
" + \"] is has a value of: [\" + myVariable.getValue() + \" ]\"\n"
" + LogColors.ANSI_RESET );\n"
"/* logger.info( \"Log Message: [\" + myVariable \n"
" + \"] is has a value of: [\" + myVariable.getValue() + \" ]\"\n"
" + LogColors.ANSI_RESET ); */\n"
"logger.info( \"Log Message: [\" + myVariable \n"
" + \"] is has a value of: [\" + myVariable.getValue() + \" ]\"\n"
" + LogColors.ANSI_RESET );\n"
"logger.info( \"Log Message: [\" + myVariable \n"
" + \"] is has a value of: [\" + myVariable.getValue() + \" ]\"\n"
" + LogColors.ANSI_RESET );\n")
subst = "/* $0 */"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.