#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Connection.*?closed\.?(?=[\n\r]|$)"
Local $sString = "return 0" & @CRLF & _
"Connection to 172.29.28.79 closed by remote host" & @CRLF & _
"Connection to 172.29.28.79 closed."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)