import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Connection.*?closed\\.?(?=[\\n\\r]|$)";
final String string = "return 0\n"
+ "Connection to 172.29.28.79 closed by remote host\n"
+ "Connection to 172.29.28.79 closed.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}