$re = '/Connection.*?closed\.?(?=[\n\r]|$)/m';
$str = 'return 0
Connection to 172.29.28.79 closed by remote host
Connection to 172.29.28.79 closed.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;