using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Connection.*?closed\.?(?=[\n\r]|$)";
string substitution = @"";
string input = @"return 0
Connection to 172.29.28.79 closed by remote host
Connection to 172.29.28.79 closed.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}