import Foundation
let pattern = #"Connection.*?closed\.?(?=[\n\r]|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
return 0
Connection to 172.29.28.79 closed by remote host
Connection to 172.29.28.79 closed.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)