re = /Connection.*?closed\.?(?=[\n\r]|$)/m
str = 'return 0
Connection to 172.29.28.79 closed by remote host
Connection to 172.29.28.79 closed.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result