# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(comment_id=)(\d+)\|(\d+)\|([^|]+)\|([^|]+)\|(\d+)/$1$2, user_id = $3, comment='$4', user= '$5', post_commented=$6/;t' <<< "comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590|2886|LOL|Baoping Wu|529360}
comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590, user_id = 2886, comment='LOL', user= 'Baoping Wu', post_commented=529360}"