using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(comment_id=)(\d+)\|(\d+)\|([^|]+)\|([^|]+)\|(\d+)";
string substitution = @"$1$2, user_id = $3, comment='$4', user= '$5', post_commented=$6";
string input = @"comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590|2886|LOL|Baoping Wu|529360}
comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590, user_id = 2886, comment='LOL', user= 'Baoping Wu', post_commented=529360}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}