use strict;
my $str = 'comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590|2886|LOL|Baoping Wu|529360}
comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590, user_id = 2886, comment=\'LOL\', user= \'Baoping Wu\', post_commented=529360}';
my $regex = qr/(comment_id=)(\d+)\|(\d+)\|([^|]+)\|([^|]+)\|(\d+)/p;
my $subst = '$1$2, user_id = $3, comment=\'$4\', user= \'$5\', post_commented=$6';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";