// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(comment_id=)(\d+)\|(\d+)\|([^|]+)\|([^|]+)\|(\d+)").unwrap();
let string = "comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590|2886|LOL|Baoping Wu|529360}
comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590, user_id = 2886, comment='LOL', user= 'Baoping Wu', post_commented=529360}";
let substitution = "$1$2, user_id = $3, comment='$4', user= '$5', post_commented=$6";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}