package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(comment_id=)(\d+)\|(\d+)\|([^|]+)\|([^|]+)\|(\d+)`)
var str = []byte(`comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590|2886|LOL|Baoping Wu|529360}
comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590, user_id = 2886, comment='LOL', user= 'Baoping Wu', post_commented=529360}`)
var substitution = []byte("$1$2, user_id = $3, comment='$4', user= '$5', post_commented=$6")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}