import re
regex = re.compile(r"<span class=\"placeholder\" code=\"(.*?)\">(?:.*)<\/span>", flags=re.IGNORECASE)
test_str = "<p>k</p><p><span class=\"placeholder\" code=\"{YSZZ}\">Samsung xyz</span> </p><p>khgj <span class=\"placeholder\" code=\"{UIDJU}\">iPhone 9k</span> </p></div>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")