// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<span class="placeholder" code="(.*?)">(?:.*)<\/span>"#).unwrap();
let string = "<p>k</p><p><span class=\"placeholder\" code=\"{YSZZ}\">Samsung xyz</span> </p><p>khgj <span class=\"placeholder\" code=\"{UIDJU}\">iPhone 9k</span> </p></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}