re = /<span class="placeholder" code="(.*?)">(?:.*)<\/span>/i
str = '<p>k</p><p><span class="placeholder" code="{YSZZ}">Samsung xyz</span> </p><p>khgj <span class="placeholder" code="{UIDJU}">iPhone 9k</span> </p></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end