# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[?!-]/<S>/g;t' <<< "\"We have examined all the possibilities, however he have not reached a solid conclusion - however we keep and open mind! Have you considered any other approach? Haven't you?\"
"