const regex = /[?!-]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[?!-]', 'g')
const str = `"We have examined all the possibilities, however he have not reached a solid conclusion - however we keep and open mind! Have you considered any other approach? Haven't you?"
`;
const subst = `<S>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);