$re = '/[?!-]/';
$str = '"We have examined all the possibilities, however he have not reached a solid conclusion - however we keep and open mind! Have you considered any other approach? Haven\'t you?"
';
$subst = "<S>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;