using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[?!-]";
string substitution = @"<S>";
string input = @"""We have examined all the possibilities, however he have not reached a solid conclusion - however we keep and open mind! Have you considered any other approach? Haven't you?""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}