use strict;
my $str = '"We have examined all the possibilities, however he have not reached a solid conclusion - however we keep and open mind! Have you considered any other approach? Haven\'t you?"
';
my $regex = qr/[?!-]/p;
my $subst = '<S>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";