#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)\bfunction\b \s*[a-zA-Z0-9._]*" & @CRLF & _
"\(" & @CRLF & _
"" & @CRLF & _
"(" & @CRLF & _
" (?:" & @CRLF & _
" (?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.)" & @CRLF & _
" (?: ,\s* (?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.) )*" & @CRLF & _
" )?" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"\)"
Local $sString = "function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd eeeeee)" & @CRLF & _
"function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd, eeeeee)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")