package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bfunction\b \s*[a-zA-Z0-9._]*
\(
(
(?:
(?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.)
(?: ,\s* (?:[a-zA-Z_][a-zA-Z0-9_]*|\.\.\.) )*
)?
)
\)`)
var str = `function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd eeeeee)
function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd, eeeeee)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}